Starting Cadence


You should make sure that you are IN '~/ee103' directory by entering 'cd ~/ee103' each time you want to use Cadence. Then you enter 'cadence &' in your console to start Cadence, a Command Interpreter Window (CIW) appears after a Cadence splash window.  An example of how the CIW looks like is as follows:

new CIW



 With each new session, Cadence starts a new CDS.log file in your home directory where all the messages that appear in the CIW will be stored. Along with the above window, you may also see the Library Manager Window , which lists all the libraries for your design. The Library Manager Window  will look like as shown below (when you open Cadence for the first time).
 
 

new library manager window




The library of great importance to you would be the library NCSU_Analog_Parts , which has standard cells and basic circuit elements like current sources, voltage sources, ground, resistors, capacitors etc. More details about the nature and use of the libraries would be given in subsequent sections.

If, at anytime during this tutorial, you want to quit Cadence, make sure you save your work by selecting Save from the Design menu and close the design windows by selecting Close from the Window menu.  This will become clear in the sections to follow.  After you have closed  all your work windows,  click on Exit from the File menu. A following window will pop up.

quit window

Click on the Yes button and you're done with the Cadence session.

From now on, a simplified convention will be used to show the sequence of steps  for the pull down menu. For example , File-->Exit will indicate that you open the pull down menu for File and then click on Exit. Another example could be Tools-->Analog Artist --> Simulation, which will indicate that you pull down the Tools menu, then click on the Analog Artist button and finally click on the Simulation button.  


previoushomenext

Adapted from  Sameer Sonkusale's  Cadence tutorial of IC 4.4.3   by Jiong Xie on Sept. 13, 2004 /html>